sony Playstation 3/4 controller support for Ubuntu 16.04

Options
Kurt
Kurt New Member Posts: 146 ✭✭
I was wondering if anyone has tried and successfully been able to setup a Playstation 3(DS3) or 4 (DS4) controller to work on the UP board running Ubuntu 16.04 using Bluetooth and have the controller setup

If so did you do it using commands like: sixpair and sixad

Or were you doing it directly using something like: sudo bluetoothctl

Thanks

Comments

  • Vladislav
    Vladislav New Member Posts: 20
    Options
    I use ds4 it on ubilinux 3.0. It is pairing well with default bluetooth manager (I also paired it with command line tool). I access to buttons/axises via evdev.
    However, there is no access to accelerometer and touchpad on evdev..
  • Kurt
    Kurt New Member Posts: 146 ✭✭
    Options
    Thanks vlad,

    I meant to reply earlier, but I fried my previous UP board (plugged 12v wallwart into power plug...)

    New one arrived. I thought I would try out my PS4 controller, but when I tried it today, it was completely dead... I tried charging it overnight, but nothing happens when I hit the PS button. I tore the unit apart and tested battery and 0v so ordered new one which should be here within about a week.

    So I pulled out a PS3 controller and charged it from my PC

    I then looked around the net and found the postings: https://askubuntu.com/questions/913599/how-to-connect-dualshock-3-controller-ps3-sixaxis-gamepad-on-ubuntu-16-04

    I downloaded and built sixad and did the manual pair and so far it appears to be working... Have not tried to reboot to see if the sixad will start when I boot or if I need to manually start,

    Will try DS4 again later when the new battery arrives
Privacy Policy