This is the area to clarify hardware specification if there's anything unclear from the datasheet. If the specification is software related, please ask in the related software section.

USB dongle stuck in port

I just tried booting up my UP Squared for the first time ever.

The only problem is that now I can't unplug the USB dongle for the wireless keyboard no matter how hard I pull or how much I wiggle it.

dWbpcQk.jpg

This second picture shows how far out it will go (about 5-10mm), then it's completely stuck:

WUza5Ie.jpg

I don't want to try to pull it harder or wiggle it even more, I've already tried as hard as I can without risking breaking the board or the USB port.

In addition, I've used this USB dongle with several devices, including a Raspberry Pi and BeagleBone Black multiple times before, and I've never had any problems with it, I'm almost completely certain the fault is not with it.
It doesn't seem to be inserted incorrectly as well as I can use the keyboard.

I'm pretty disappointed right now as I was really looking forward to trying out my new UP, and I wasn't planning on keeping this keyboard with the device (it's my spare and I was going to use it as a headless device), so if I can't fix this myself I really hope the warranty will cover it.

Should I mail UP directly as well?

Comments

  • AlingAling Posts: 492Administrator, AAEON admin
    Hi Enil,

    The USB ports of UP family is following the industrial standard, which requires certain pull-force to detach USB device, so that UP family can be used in the vibrating environment.
    I experienced something similar as you did. Just make sure your USB device is strong enough, especially the plastic part, then pull it. :-)
Sign In or Register to comment.