Win 10 on Up2 - need startup help

Robert SheltonRobert Shelton New Member Posts: 109
I am attempting to install Win10 64bit from an ISO installed on a usb stick. The only semi-working path is thru "CD or DVD" installation. It starts, but I am stuck at a dialogue telling me that a driver is missing. Could anyone clarify if Win10 is pre-loaded on the Up2 - and if so, how do I boot it? Otherwise could someone supply a URL to installation instructions? Seems that others have experienced driver issues on installation, but I didn't see a resolution posted.

Thanks!
Robert

Comments

  • AlingAling Administrator, AAEON, UP reseller Posts: 524 admin
    UP^2 doesn't have any OS preloaded.
    Here is Windows installation guide of UP, it works almost the same for UP^2. We will make the Windows installation guide for UP^2 soon.
    https://up-community.org/downloads/download/21-microsoft_windows/17-up-x5-z8300-01_a02_windows_10_installation_guide
  • Andy NicholsonAndy Nicholson New Member Posts: 61
    Also sounds like you might need to update your install ISO, I have problems with graphics drivers, but not for anything including drives during installation with the latest "Creators Update" ISO.

    At what point during the install is it asking for drivers?
  • Robert SheltonRobert Shelton New Member Posts: 109
    I see the install starting screen (purple background). After an extended pause, the Collecting information screen is in the background overlaid with a Select the Driver to install dialogue. Over that is a Load driver dialogue with browse, ok and cancel. It says a media driver your computer needs is missing. This could be a dvd, usb or hard disk driver. It asks me to insert a usb with the needed driver. But I'm not sure what driver is missing. My display is HDMI, and obviously that works. I have pretty basic wired keyboard and mouse plugged in (HP, but brand doesn't matter). My USB key is a Lexar adapter with a 32G high performance micro SD card. I've used this setup to configure my Up-board v1 units. Worked fine, although that was Linux. I assume the USB can be read bc I'm getting this far in the install. So, the puzzlement is which driver is missing given that the select driver to install dialog offers no drivers at all; and unchecking the compatibility box also displays nothing.
  • Andy NicholsonAndy Nicholson New Member Posts: 61
    edited June 2017
    1) Are you using the latest version of Windows 10 (Creators Update / 1703 )

    2) If you are at the stage where it's asking where to install to, it's almost certainly drivers for the onboard storage. Unless there are different chips in different UP2 boards, or you are installing to to a storage device you have added, W10 v1703 should be fine. I didn't have any problems at this point, mine are afterwards and appear to be for other reasons.

    3) If you're installing to a device you've added (mSATA etc) easiest thing is to get the drivers, extract them onto your installation source media and navigate to there when asked during the install.
  • Robert SheltonRobert Shelton New Member Posts: 109
    I downloaded the Win10 iso as recommended and have installed it on the micro SD two ways: one using Apple Pi Baker, and the other using drag and drop. The "press any key to boot from CD or DVD..." prompt no longer appears. My Up2 goes immediately from the blue AAEON/ASUS screen to the EFIO shell. Any suggestions?
  • Andy NicholsonAndy Nicholson New Member Posts: 61
    Sounds like you made the USB media with BIOS boot not UEFI, in order for the UP2 to boot to a USB drive it needs to be UEFI, and I think FAT32 but not sure about that last one.

    Not sure about Mac's but on my PC I use Rufus.
  • Robert SheltonRobert Shelton New Member Posts: 109
    edited June 2017
    I rebuilt the micro SD using the latest Rufus. Selected MBR for UEFI. Used image Win10_1703_SingleLang_English_x64.iso. Rufus set the parameters for me once I picked the iso. Process completed successfully. Ejected SD and rebooted my U2 with the SD in the adapter. It still goes directly to EFI Shell prompt. No opportunity is presented to boot from CD or DVD, which was the way I accessed the Win installer previously. Are there commands that I can use at the EFI shell to initiate the installer? Or is there a config that I can / need to set so the option is presented on the next boot?
  • Andy NicholsonAndy Nicholson New Member Posts: 61
    But did you change the setting back to "FAT32" and "MBR partition scheme for UEFI" after loading the ISO? And not the "MBR partition scheme for BIOS or UEFI" version. For me, anything other than this failed.

    Personally I'd also use a "regular" USB thumb drive rather than a mounted SD card, just to rule out potential problems, but if that is all you have then just go with it.
  • Andy NicholsonAndy Nicholson New Member Posts: 61
    edited June 2017
    Just found another option thanks to a comment from YouTube -

    <inset USB key>
    <power on into UEFI>
    mount blkX (where X is the nuber of the usbkey)
    blkX:
    cd <tab> (press <tab> for completion)
    cd <tab>
    <tab>

    Like I Say, no idea about EFI shell commands but might be worth a try.
  • Andy NicholsonAndy Nicholson New Member Posts: 61
    Nexusnet, I'm curious - did you get things working?
  • Robert SheltonRobert Shelton New Member Posts: 109
    Thought I had posted an update - looks like not. Yes the install is working. In fact, I'm using the Up2 as a replacement for my MacAir / Windows VM that died a couple of months ago. Ironically the Up2 is more performant and much more reliable, at a fraction of the cost. It even runs Win 10/Office 2016 faster than my maxed-out 1-year-old iMac/VM. I'm eagerly awaiting arrival of the Up2 plastic case and usb add-on board - having a blast with build-your-own-tablet-PC!

    So... debrief on what I learned:

    One problem was UEFI boot settings. It took me a while to figure out that the Up had reset after my first Win10 load attempt; and was trying to boot from internal storage instead of my USB "dvd". On my first install attempt, the setting was correct (use USB), but I didn't anticipate that the failed install would leave the boot configuration changed. I recall having to fiddle with this config a bit before it worked - may have needed to change more than just the one parameter but don't recall.

    The second problem was that my iMac / Fusion VM was getting confused during the Windows process of creating the UEFI "dvd" from the iso. Basically the Win VM would think that the disk had disappeared / ejected, and would terminate the disk write process. This happened at widely varying, seemingly random places in the process. In fact, the first time I tried building the "dvd", the process succeeded... except that I had used the wrong version of Win10. Rufus worked perfectly once I "permanently" assigned the usb device to Windows rather than using the standard "ask what to do" setting in Fusion.

    General note: if one can avoid using a Mac/WinVM for any task/program that must run on Windows, do so. Fusion VM reliability on OS X has deteriorated over the last 3+ years. Unfortunately I didn't have a Win PC at the time - was entirely Mac and Linux. I have a Windows PC now. ;)

    Thanks for the assist during my adventure!
  • David RolfeDavid Rolfe New Member Posts: 98
    AlingWu wrote:
    Here is Windows installation guide of UP, it works almost the same for UP^2. We will make the Windows installation guide for UP^2 soon.
    https://up-community.org/downloads/download/21-microsoft_windows/17-up-x5-z8300-01_a02_windows_10_installation_guide
    Hi,

    I have just been reading through some old threads, and wondered if a specific Windows 10 installation Guide for the UP Squared board has been completed yet?

    Thanks!
Sign In or Register to comment.