Everything working on Centos 7.3 but the 40 pin header

JOSHUA SIRKIN
JOSHUA SIRKIN New Member Posts: 15
Hi, I have been running the upboard successfully for a few months now on Centos 7.3 with Kernel 4.4.46-1 from ELREPO. It all just installed and worked fantastically. The only piece I am missing right now that I would love to get working is the gpios. I think I found the drivers here,

https://github.com/mopplayer/upboard-mainline-4.11/blob/master/v4.11-rc2/drivers/platform/x86/up_board.c
https://github.com/mopplayer/upboard-mainline-4.11/blob/master/v4.11-rc2/drivers/platform/x86/up_board_pinctrl.c

Any chance those will ever get built into drivers for Centos? I think that is really one of the last missing pieces.

Comments

  • DCleri
    DCleri Administrator, AAEON Posts: 1,210 admin
    Hi jfsir,

    Unfortunately there are no plans of official support for other distributions like CentOS or OpenSuse.
    The only way would be for someone from the community to make the kernel or an image available with such changes.

    If you need CentOS for a specific project we might be able to help you with our professional services, feel free to contact us: https://emutex.com/about-us/contact-us

    Also we are working on the upstreaming of the UP^2 drivers (which will also support UP and UP Core). Thanks to this effort you might be able to get all the UP/UP^2/UP Core features from a standard distribution in the future.
    If everything goes well we might get the drivers upstreamed by the end of the year, hopefully sooner.