Ubuntu installation error

Douwe van Nijnatten
Douwe van Nijnatten New Member Posts: 5
Hello All,

i have got a couple of UP boards and I am trying to install Ubuntu 16.04 LTS on all of them. Out of the 7 devices, 6 installed without any hassle. The 7th however, not so much. I am using the same usb device with the same image on all of them. When installing the 7th device, I (consistantly) get the following message: "the ext4 file system creation in partition #2 of MM"c/SD card #1mmcblk0 failed". Is there anything I can do to circumvent this problem? Or should is this a hardware issue and should I return the device?

Best regards,
Douwe

Comments

  • DCleri
    DCleri Administrator, AAEON Posts: 1,210 admin
    HiDouwe,

    Are all the boards the same?

    On the boards that present the eMMC issue could you please check logging in the BIOS what is the eMMC part?
    Also, once the board is off and completely disconnected from the power source, please try to reset the BIOS unplugging and, after few minutes, replugging the RTC battery.
    Then try again to install the Operating System.

    If it fails again, try to boot the live Ubuntu system and open the program GParted.
    If you can see the mmcblk0 from there, you should try to remove and create again the GPT partition table.
    Then try to install the system again.

    If even this doesn't work you should contact the UP Shop and request an RMA.
  • Douwe van Nijnatten
    Douwe van Nijnatten New Member Posts: 5
    Hello dcleri,

    Thank you for your help. I have got two versions of the boards: UP-GWS01-A10-1432 Rev.A0.3 A9GA5 and UP-GWS01-A10-1432 Rev.A0.3 A7301. The one that's failing is from the A9GA5 revision.

    I have tried to disconnect the RTC and reinstall, but no success.
    When I open gparted, I can see the partition table and it explicitly reports a problem on partition 2. Partition 1 (EFI System Partition 512mb) and partition 3 (Swap 4gb) are fine.
    Using GParted, I have tried delete and recreate partition 2. I get the following errors: "mke2fs Warning: could not erase sector 2: attempt to write block to filesystem resulted in short write". I found some sectors which were giving errors. I created partitions in between them and tried to install ubuntu there. This time the installer simply crashed. When I run dmesg, I see a lot of errors on mmcblk0 like:
    - card_busy_detect: error sending status command
    - mmc0 Card stuck in programming state
    - mmc_blk_cmd_recovery: general error sending stop or status command
    - cache flush error -110

    From here on out, I am out of ideas. I think I will contact the vendor and see if I can get another one.

    Again, Thanks for your help,
    Best regards,
    Douwe