[SOLVED] Problem encountered with this UP board

Gilmar
Gilmar New Member Posts: 18
edited June 2016 in UP Board Linux
Hi,

Problem finding the recommended image:
I can't find ubilinux in your Download page. Where is it?

Problem Installing yocto:
So I tried yocto x64, well, booting only on usb stick is fine but installing it doesn't go as expected.
The problem was
can't access tty; job control turned off
Tried the solution here but it doesn't help.

Problem with USB OTG/Instruction:
Also, how could I make the USB OTG to output to console on my PC? What tools to use, in UART I can use teraterm and similar terminal emulator.
Your website doesn't provide such help.

Problem with the board:
One problem with this board though, if I'm using HDMI and at the same time tried to plug a USB 3.0 micro it doesn't work, I can't connect the usb micro to the port because each port are very close to each other.

Hope someone could take a look at this and shade some light.

Thanks

Comments

  • Javier Arteaga
    Javier Arteaga Emutex Posts: 163 mod
    Hi gilmar,

    Sorry for the late reply.

    ubilinux download
    If you have received an UP board, you should be able to find ubilinux images here:
    https://up-community.org/downloads/ubilinux™
    Please let me know if you still can't access the downloads.

    Yocto
    Are you using the UP yocto layer provided in the downloads section? If so, I'll raise this issue with the relevant developers.

    Serial console through USB3.0 OTG
    This information hasn't been added to the wiki page yet. I'll let you know as soon as the procedure is tested and documented.

    USB3 and HDMI ports
    Unfortunately, the connector placement does cause issues with some bulkier HDMI/USB3 adapters. It's definitely possible to use both ports at once (as we often do internally), but you might need an extra cable in some cases.

    Please let me know if you have any further questions.
  • Gilmar
    Gilmar New Member Posts: 18
    Thank you for the reply.

    I was able to install and run ubilinux on my up-board. This is great.
    Yocto : The yocto image I tried was not from up-board page, I downloaded it from yocto's website, because there is no yocto page on up-board website when I started this post.
    Now, the UP yocto layer link that you mentioned on your reply is empty. Clicking in the YOCTO on that page return "404" error.

    Thanks
    gilmar
  • Javier Arteaga
    Javier Arteaga Emutex Posts: 163 mod
    Hi gilmar,

    The documentation for serial console through USB3.0 OTG is now available at:
    https://up-community.org/UpWiki/index.php/Serial_console#USB3.0_OTG_port_in_device_mode

    Don't hesitate to contact me if you have any issues with the procedure.

    Regards
  • Gilmar
    Gilmar New Member Posts: 18
    thanks, I'll take a look on it.

    what about the yocto page, is it available now? if not when?

    thanks
  • Gilmar
    Gilmar New Member Posts: 18
    Hi jarteaga,

    I've tried instruction here for USB3.0 OTG port in device mode, however, I got an error "modprobe: ERROR: could not insert 'g_serial' : No such device".

    I also change the USB OTG support in bios from ACPI to PCI but still the same error.

    How can I fix this?

    Thanks
  • Javier Arteaga
    Javier Arteaga Emutex Posts: 163 mod
    Hi gilmar,

    The USB OTG Support BIOS option should be set to PCI mode (thanks for pointing that out, I'll update the guide). Indeed, I can reproduce your issue in ACPI mode. Was ACPI the default on your board? It should be PCI.

    However, the guide steps work for my board when switching to these settings:
    USB OTG Support: PCI mode
    Default DRD Config: DeviceMode
    You may want to review these BIOS settings, as well as any other USB settings that might have been changed from the default values.

    Otherwise, that error for [tt]g_serial[/tt] may indicate that another kernel module has already reserved the USB port. This shouldn't happen in a default ubilinux system. Could you please try these steps:
    [ul]
    [li]Boot the board from the powered off state[/li]
    [li]Login and follow the steps again right after that[/li]
    [/ul]
    If at that point you still get the same error, could you please send the output from these two commands?
    sudo lsmod
    dmesg
    

    Thanks for your feedback.
  • Dan O'Donovan
    Dan O'Donovan Administrator, Moderator, Emutex Posts: 241 admin
    One other suggestion. In case you haven't done so already, make sure you have the latest kernel version installed:
    sudo apt-get update && sudo apt-get dist-upgrade
    
  • DCleri
    DCleri Administrator, AAEON Posts: 1,189 admin
    Hi Gilmar,

    The Yocto download link will be available as soon as the new meta layer to support the Mass Production board will be released .

    Are the answers provided sufficient to clarify your issues?
  • Gilmar
    Gilmar New Member Posts: 18
    Hi dan and jarteaga,

    The USB 3.0 OTG as device mode is working fine now. It's probably the update that fixes it.

    Thanks
  • Gilmar
    Gilmar New Member Posts: 18
    Hi dcleri,

    Thanks for the clarification.
    Are the answers provided sufficient to clarify your issues?
    Sometimes, when multiple questions asked in a single post some other questions get neglected/ignored and need to re-post the same question to get the answer. And sometimes question/s don't get answered. As for this post, everything are cleared now.

    Please answer my other question about mipi-csi camera for up-board.


    Thanks