Connecting EnOcean FAM4PI to Up Board

Tenio New Member Posts: 2
Could someone from the engineers suggest a guide on:
[li]How to connect the FAM4PI board to Up board[/li]
[li]How to get data out of the wireless switch from Eltako through FAM4PI[/li]
The closest guide I could find is
but unfortunately FHEM does not recognize the EnOcean board in my case.


  • Dan O'Donovan
    Dan O'Donovan Administrator, Moderator, Emutex Posts: 241 admin
    Hi Vachev

    Sorry for the delayed reply. The FAM4PI board can be connected to UP by plugging it onto the 40-pin I/O header. Align it with pin 1, which is at the end of the board furthest away from the Ethernet and USB2.0 sockets (same as how it would be connected on a Raspberry Pi).

    It connects to the UP board via UART. If you are using our ubilinux distrubution, you can access that UART via '/dev/ttyS1' or '/dev/ttyAMA0' (which is simply an alias for /dev/ttyS1 on UP).

    I haven't used FHEM myself, but I have used the software library linked in the following tutorial:
    I remember that I did have to make some minor changes in that library though before it worked properly on UP:
    [li]Add -fPIC to the compiler flags. Otherwise the linker throws an error[/li]
    [li]Add CREAD to the TERMIOS flags where the UART device is opened. Otherwise it looks like the receiver on the UART doesn't get enabled properly.[/li]

    I hope that helps.

  • Tenio
    Tenio New Member Posts: 2
    Did everything - working, but for some reason cannot read anything over the serial port? ( compiles, links, opens the serial ok). Any ideas? Trying with a number of switches but no telegrams ...
  • Aling
    Aling Guest Posts: 561 admin
    We got some reply from our partner from EnOcean , soon they will join us to support questions about EnOcean kit.

    i test the solution on UPLinux RC2.

    1. The user have to check the configuration for Serial Port 1 (have to disable) in Bios.
    a. [Advanced]->[Serial Port Console Redirection]
    2. Restart System and open Console window for testing the connection
    3. change the Configuration of ttyAMA0
    a. sudo stty -F /dev/ttyAMA0 57600
    (configure the COM port to 57600 Baud)
    b. sudo hexdump < /dev/ttyAMA0

    Now, send some enocean radiosignals.
    After some secounds, the hexdump command show the raw data of EnOcean Signals.

    0000000 0055 5d0a 00f4 ff01 ffff 5cff 3000 0055
    0000010 070a eb01 00d1 21b0 0001 db8a 002e ff01
    0000020 ffff 36ff 7e00 0055 070a eb01 00d1 21b0
    0000030 0000 db8a 002e ff01 ffff 34ff c000 0055
    0000040 070a eb01 00d1 21b0 0001 db8a 002e ff01
  • Alfred Neumayer
    Alfred Neumayer New Member Posts: 1
    Having similar issues using the FAM4PI on my Up Board.

    I've tried the latest EnOcean Link Trial, got it to build and link perfectly fine on Ubilinux 3.0.
    Sadly though, the tutorial and example applications (after changing all Serial Device paths to /dev/ttyAMA0)
    don't work reliably, subsequent restarts of the examples causes an indefinite hang at open()ing the device.

    Console redirection is disabled in the BIOS so I wonder what else would be different to e.g a Raspberry Pi
    and could cause issues with the FAM4PI adapter.

    Interestingly, the Python EnOcean communicator library (pip install enocean) works without hiccups.
Privacy Policy