Up board "out of the box" booting directly to EFI Shell

AndreAndre New Member Posts: 9
I just received a brand new Intel RealSense Robotic Development Kit.

I took the up board out of the box, made sure the battery and the cooler were ok, connected the HDMI cable, keyboard, mouse and then the power adapter.

The Up logo was shown on the monitor and then it went directly to the EFI Shell. I tried everything I could: reset the bios settings, unplugged the battery, reset again, nothing.

Under BIOS -> Boot -> Boot Options Priorities is empty.
Under BIOS -> Chipset -> South Bridge: eMMC Unknown M52532 29626D14 (29.1 GB).
I changed the setting on BIOS -> Boot -> OS Image ID from Windows 8.1 to Android and tried both. Same behavior.

I tried to boot using a bootable USB with Windows 10 and it won't detect it. Same thing with Ubuntu bootable installation.

Am I missing something? Is this board broken?

See the output I'm getting attached.
Thanks in advance

Comments

  • GiuseppeGiuseppe New Member Posts: 2
    Hi Andrea,

    I have the same problem with the same model of board.
    This problem arise after a power failure and an eMMC
    filesystems disaster.

    I can boot an Ubuntu USB image pressing "F7" or "F9"
    key at board startup and selecting the USB device as
    startup device.

    I have repaired filesystems (EFI VFAT included) using
    fsck but the board doesn't boot yet.

    Any idea about this problem)
  • AndreAndre New Member Posts: 9
    edited March 2017
    Hello developer,

    It seems you are better than me.
    When I hit F7 to select the start up source, I get no items :(
  • AndreAndre New Member Posts: 9
    I could fix my issue upgrading the UEFI Bios using the files provided in this link: https://up-community.org/downloads/category/15-up

    Also, check if your UEFI is x32 or x64, the instalation of your OS should match the same architecture and your usb filesystem should be FAT32.

    Windows 10 full running just fine now!

    Thanks!
  • GiuseppeGiuseppe New Member Posts: 2
    Hi Andrea,

    I'm not so lucky!
    For the problem reported in my previous reply (My UP doesn't boot and it goes in the UEFI shell),
    I have Ubilinux installed on 3 partitions: / , /home, /var.
    Unluckly, in a production environment of 4 upboards, one of them cannot boot at all.
    Analyzing the problem I have noted a corrupted filesystem in the "/" partition.
    So I have recovered this way:
    - Boot with ubuntu usbkey
    - fsck /dev/emmcblk0p3
    The fsck program has successfully recovered the partition but the UPBoard didn't boot yet.
    So I've checked the efi partition /dev/emmcblk0p2 and some errors have been found.
    So I've executed fsck on that partition, reinstalled grub and...voilà...the boot.
    All happy for the result but me!!!
    Indeed, as I expected, rebooting the UPBoard, it hangs again showing the EFI shell.

    So, I state (and I hope someone contradicts me) that the internal flash is definitively broken.

    Now my question is: Is the UPBoard so sensible to istant and unpredicatable power losses
    that its internal flash can be easily broken down?
Sign In or Register to comment.