What USB WiFi dongle for 5Ghz UbiLinux *and* Android Support?

KenKen New Member Posts: 48
There doesn't seem to be many of these WiFi Dongles that state what chip they use, so selection would seem to be pretty hit and miss. I can make the assumption that there probably isn't any of these that aren't supported by Windows, so it's not really even worth asking. Generally speaking, I can also assume that pretty much any one that claims Linux driver support can probably be made to work on UbiLinux, although seems some are less trouble than others, which ones appears to be based on chipset details that are almost universally unknown particularly in newer N and AC versions. Android Marshmallow and Nougat support is another story, this seems to be very specific and limited from what I've read so far, having to do with increasingly closed driver details in this market and a revamp of how Android loads drivers in newer releases.

So what I am looking for is a USB WiFi dongle with particularly good driver support, operates in 5Ghz frequency, preferably AC although I'd trade AC for N to get a higher likelihood of working. My focus is more centered on UbiLinux, however I would like to also be able to explore Android options. For no reason in particular, I'm looking at these two products:

ANEWISH 600Mbps USB Wifi Adapter, Dual Band 2.4G/5G Wireless Wifi Dongle Network Adapter for Laptop Desktop Win XP/7/8/10, MAC OS X 10.6-10.9, Linux 2.3/2.6/4.3

-And-

ASUS Dual-Band Wireless-AC600 Wi-Fi Adapter (USB-AC51)

Both state Linux support, and both are AC, neither of course claim Android support and honestly I've found no 5Ghz dongles that do, N or AC, at least none that states releases, which apparently with Android is important since the driver structure changed somewhere around the KitKat/Lollypop time frame so I am assuming any product claiming Android support that is more than a few years old may not actually support newer distributions. The ASUS product is certainly pricey compared to almost any other WiFi dongle, but not so much so that it eliminates it from my search. The ASUS is also the only AC dongle I've found that claims Linux support and isn't from some completely random company. Netgear also has an AC600 dongle but does not claim Linux support, and is also not in the cheap category, but their A6100 would also be a candidate if anyone has any experience with it:

NETGEAR AC600 Dual Band Wi-Fi USB Mini Adapter (A6100)

Oh and I am specifically looking for a small Chiclet style adapter for space packaging reasons.

Comments

  • WereCatfWereCatf New Member Posts: 201
    I spent like a week just scouring the net, trying to find some 5GHz-capable WiFi-adapters for use with Linux and nearly all of them, including the ones you linked to, require you to use an outdated kernel and to compile some buggy, proprietary driver which just barely functions, if it functions at all! I did, however, find out that dongles that use RT5572 or RT3572 are supported by F/OSS-drivers and the driver is already in the Linux-kernel.

    I just got a few of both kinds of dongles a few days ago and sure enough, they work just peachy under Linux. As for Android-support -- I have absolutely no idea.
  • KenKen New Member Posts: 48
    edited February 2017
    So these are "N" only chips? ... or I guess I should say A/B/G/N. Looking them up on wikidevi there is nothing Chiclet sized, they're all pretty huge.... not even bendables. There does seem to be some open board versions that I suppose could work for me if I adapted them to the extra USB header. Seems like a way more complicated path though, took a quick look at the header adapter from the UpShop, and I am not even sure I fully understand what's going on there, like what is the 3 pin connector for? and I am sure it wouldn't be so easy to simply find a prewired 10 pin connector like that by itself. Looks like a connector you can't exactly crimp yourself without a specialized tool.

    You wouldn't happen to have a list of all WiFi chips in the F/OSS drivers would you?
  • KenKen New Member Posts: 48
    Huh, looking at the https://wiki.debian.org/WiFi page, didn't realize the situation was that hosed. Only one N chipset is actually open source and it's 2.4Ghz only (Atheros AR9170), pretty sad. Problem I have is 2.4Ghz is completely clobbered where I am, there is at least a half a dozen APs on every channel in 2.4. Even in 5.8, I've opened up ATC frequencies to get some open air, where I can get about 250Mbps. In 2.4, I am lucky to see 20, I'd actually be better using A. But I see on that list that the RT chipsets aren't fully open either, is it just a better provided driver?
  • WereCatfWereCatf New Member Posts: 201
    Irwin wrote:
    But I see on that list that the RT chipsets aren't fully open either, is it just a better provided driver?

    The RT-chips I mentioned have a driver in mainline Linux-kernel and the driver itself is open-source. There is a firmware-blob, but that is also distributed with the kernel, so they are more-or-less the best-supported 5GHz-capable USB WiFi-chips. That is to say, they are just plug-and-play.

    I did spend several days trying to find better options, but, in general, USB-based 5GHz-capable stuff just isn't supported under Linux, unless you want to mess with compiling kernel-modules and dealing with extremely buggy hacks. I just can't find anything better than those. Certainly, if you do, I'd love to know about it.
  • KenKen New Member Posts: 48
    In the end I just need 2 NICs and was looking at WiFi to provide my "Public" NIC. Given the issue with the drivers I may very well end up using one of the many Asix USB-Ethernet adapters to get that 2nd NIC off the USB3 port. I do have a specific need for Wireless eventually in my projects but I am not entirely sure at this point the UP board can actually fulfill that particular function, I need to be able to bury one into an automotive steering wheel mount with a UPS that can be charged by the horn button contact. I am just not sure the UP is actually small enough.
  • KenKen New Member Posts: 48
    edited February 2017
    Based on the replies from WereCatf and others looking for a supported solution for WiFi in the 5Ghz space, why is it that this kit:

    wifi-kit-for-up.jpg
    WiFi kit for UP

    Isn't using this module:

    1466062625_s.jpg
    GWF-4M01 Ogemray WiFi Module RT5572 Chipset

    It's similar in size (15x30mm vs 14x28mm), looks like same antenna interface, same USB header interface, support A/B/G/N in 2.4 and 5.8Ghz frequencies, same supplier. And sounds as if the RT5572 is a well known, somewhat sane driver at least through 4.4 kernels.
  • KenKen New Member Posts: 48
    There are also several variations of this module:

    sparklan-wubr-508n-pu-802-11a-b-g-n-2x2-mimo-usb-module-with-printed-antenna-usb-type-a-ralink-rt5572-10.jpg
    sparklan-wubr-508n-p4w-802-11a-b-g-n-2x2-mimo-usb-module-with-printed-antenna-4-pin-wafer-ralink-rt5572-1.jpg
    sparklan-wubr-508n-p4-802-11a-b-g-n-2x2-mimo-usb-module-with-printed-antenna-4-pin-connector-ralink-rt5572-1.jpg

    Same Ralink chipset as above (RT5572) though not at the same price point, there is actually many versions of this board with either built-on or headered USB, printed or external antenna, made by, or at least sold via the SparkLAN brand name.
  • AlingAling Administrator, AAEON, UP reseller Posts: 526 admin
    Thanks for all of your tips.
    The challenge is MOQ and price. We do find some pretty nice module, but the MOQ start from 10,000pcs. :-(
    We will definitely look into your suggestion and see what we can find.
  • WereCatfWereCatf New Member Posts: 201
    Everything, including the kitchen sink and neighbour's dog, is using the 2.4GHz band nowadays and it's horribly, horribly congested. Personally, I consider it a major negative point on any new device, that is WiFi-enabled, but only does 2.4GHz-band -- there's no good excuse for that anymore these days.
  • KenKen New Member Posts: 48
    I see the Ogemray part carries a quantity minimum of 500-1000 pieces depending on broker, I don't know how that fits into the Up accessory model, but it is the same manufacture as the one used in your current "kit", and seems to carry a price per piece of between $5.35-7.90, again depending on broker.

    The second one I listed is end consumer targeted and has US and European distributers, although it does not carry an integration friendly price tag, it's in the $30-40 per piece area. I included it as a potential for Up board users here looking for something in a open module device that appears to work. There are also a couple of dual frequency AC modules available from SparkLAN and Embedded Works using the MediaTek MT7612U and Realtek RTL8812AU respectively, however it seems like the MediaTek chipset is particularly cumbersome to get working, if at all, and the Realtek chip seems like a lot of hoops as well, although the end result sounds like it may actually work ok, but not by any means plug and play.

    ...and for anyone following along here, considering an open module connected to the USB2.0 header, It seems prewired header pigtails are fairly common on eBay, usually in bundles of 10-20 pieces for under $10. Correct me if I am wrong here, but it appears to be a Mini-Micro JST 1.0mm pitch 10pin connector.
  • KenKen New Member Posts: 48
    WereCatf wrote:
    Everything, including the kitchen sink and neighbour's dog, is using the 2.4GHz band (...)

    Pretty sure our neighbors dog is using Bluetooth, he keeps trying to pair with everything.
  • KenKen New Member Posts: 48
    I received the SparkLAN module (RA5572) and I am testing it, seems to work, well until it doesn't, but I think this is really the fault of wicd and not the module.

    <RANT>
    Wicd seems to want to trash one network in favor of another, developers page says that it doesn't support multiple simultaneous network connections at this time, which to me seems kind of dumb, I mean what exactly is the point of a network manager that can't manage networks only a network. If there is any kind of burp in the WiFi it seems to just drop it, and does not revert to wired, unless you "prefer" wired in which case it won't connect to WiFi at all if wired exists. I assume it will happily reconnect if initiated from the box itself, but if you can't get to the box because it dropped the network.... This just seems silly to me, and meanwhile ifconfig and iwconfig are officially listed as "deprecated" because they are being migrated to interfaces like this that require X and don't have the function of what they are supposed to replace. Now I guess I have to remove wicd and it looks like network-manager needs a bunch of gnome libraries to function on LXDE (the UbiLinux default) at which point you might as well just install Gnome or KDE.

    ...on the other side of this network-manager itself is not a wonderful program, and basically just generically lumps all the NICs together generically without regard to what network segments the NICs exist on, and you basically have to go through a couple layers of naming translation to set up what takes a couple minutes to do in startup scripts. It does handle and differentiate between WiFi and Wired though and gives you a GUI for ESSID discovery, so wouldn't be too bad for this, but it is a nightmare on a machine with a couple of quad cards and VMs running on top of that. I try and play along with the future, but wicd and network-manager are frankly just not very well thought out solutions to a problem that didn't really exist to begin with. Right now my Up Boards are setup for mostly remote access only and I am fairly sure if I remove wicd I will turn them into network islands without de-configuring some things first to redirect video back to the HDMI, right now I have them boot to a 3.5" TFT display which doesn't have enough screen resolution to open up anything with a larger interface, even network-manager will probably be a problem.
    </RANT>
  • KenKen New Member Posts: 48
    BTW, just want to add, this is going to probably be a problem with the Up2 and UbiLinux as it stands today being that it has 2 NICs and a dedicated WiFi expansion slot. Wicd, isn't going to cut it, and network-manager isn't going to work without bloating up the desktop manager, just want to point this out to the Up folks.
  • WereCatfWereCatf New Member Posts: 201
    I've tried wicd a couple of times and I find it just downright terrible. But I ain't got any trouble with NetworkManager, it works fine on all the different devices I've got, but then again, I don't have a particularly complicated network-setup.
  • KenKen New Member Posts: 48
    Yea, try network-manager with a couple of quad cards some time, it creates some weird matrix of every possible combination of ports mapped to every possible combination of aliases, which are the same names as the ports, so you end up with like 64 possible combinations of which 48 are invalid combinations and the ones that are valid have to be remapped because they are nonsense, like interface p1p1 is mapped to logical name p2p4 and p2p4 is mapped to p1p2, etc... and you have to de-associate the logical mapping before you can remap them and when you do it reorders them all and there is 7 other logicals with the same name as the one you just de-associated, it's an unmanageable mess.
  • TeknikLTeknikL New Member Posts: 1

    I know it's an old thread but I had instant success with the TP-Link AC1300 High Gain Wireless MU-MIMO usb adapter on my android tv box, plugged it in and booted and the thing worked! just to help others.

Sign In or Register to comment.