Wifi Dongle

JevgenijJevgenij Posts: 3New Member
Hello,

I have installed ubilinux on my upboard. Completed installation without wifi dongle inserted. However, after the installation the dongle is not recognized? What could I do to solve it?

Thank you!

Comments

  • Dan O'DonovanDan O'Donovan Posts: 218Emutex mod
    What type of WiFi dongle is it, jevgenij?
    (brand & model number)
  • JevgenijJevgenij Posts: 3New Member
    Thank you for your response, Dan,

    It is LB-Link BL-WN2210 300Mbps Wireless usb adapter. It is part of upboard standard package.
  • Dan O'DonovanDan O'Donovan Posts: 218Emutex mod
    edited February 2017
    I've just tried this on my UP board now with a TP-Link version of the same dongle (it uses the same chipset), and I think I'm seeing the problem that you're seeing. When I enter the Wicd Network Manger, no wifi networks are shown. And running 'sudo ifconfig' doesn't show a wlan0 interface. Is that what you're seeing too?

    I did get mine working though. In my case, running 'sudo ifconfig -a' did show that wlan0 was there but not configured. I opened the preferences pane in Wicd and added 'wlan0' as the Wireless interface in the 'General Settings' tab (not sure why it didn't discover it by default). Once I did that, the wifi dongle started working and it discovered the various WiFi networks in my vicinity.

    Hope that helps. If you don't see 'wlan0' when running 'sudo ifconfig -a', then the problem is most likely something else.

    Cheers,
    -Dan

    P.S. I strongly recommend following the instructions here to replace the drivers for your WiFi dongle once you get it up and running:
    https://up-community.org/wiki/Wireless#Realtek_WiFi_dongle_issues
    There's a memory leak problem with the built-in drivers.
  • JevgenijJevgenij Posts: 3New Member
    After following you suggestions it worked! Thank you
  • ThomasThomas Posts: 18New Member
    I have the same issue and I replaced the drivers, but I can't get the wifi working.
    I installed ubilnux a while ago and just got the LB-Link wifi dongle from the up shop a few days ago.

    Could you give me any advice on how to get this working?

    Thanks,

    Thomas
  • Dan O'DonovanDan O'Donovan Posts: 218Emutex mod
    From the instructions above, what steps have you performed so far?
  • ThomasThomas Posts: 18New Member
    I did the /opt/install... command. I actually got it working.

    Thanks!

    Thomas
  • brucebruce Posts: 15New Member
    Hi there, I have the same issue, I have TL-WN823N, it works with my windows machine but not with the UP board.
    when I type this command
    lsusb
    
    , the name of the dongle is totally blank,
    Bus 001 Device 012: ID 2357:0109

    I also followed your instruction Wicd Network Manager -> Preferences ->General Settings

    Here, I already have
    Wireless interface: wlan0
    Wired Interface: eth0
    Still Wicd Network Manager shows No wireless network found

    One more thing, in Advanced Settings I have more than one options available in Driver: and they are
    none
    nl80211
    wext
    none


    what should I do in this case?
Sign In or Register to comment.