Having some trouble installing CoreOS on the UpBoard

Ravenix
Ravenix New Member Posts: 4
Hi All,

I want to install CoreOS on 5 UpBoards to put them in a cluster. I tried to install Ubuntu Server on them and that worked like a charm, but now I need something different. According to their documentation I have to boot to an USB and then run a script which installs it bit by bit to a destination.

I am looking for an OS to boot on USB, I've tried to boot to Gnome Ubuntu and Ubuntu itself on USB, but it fails to boot. Does anyone have an suggestion for an OS to use? The UpBoards I use are the 4GB RAM + 64 GB eMMC. Or maybe even other suggestions, like something I'm doing wrong?

Greetings,

Ravenix.

Comments

  • Dan O'Donovan
    Dan O'Donovan Administrator, Moderator, Emutex Posts: 241 admin
    Sorry for the delayed reply. In case its still useful, when you say "it fails to boot", do you mean perhaps that it doesn't boot from the USB stick by default when an OS is already installed?

    If that's the case, you can try pressing F7 during the BIOS start-up and it should present an option to boot from the USB stick. If it doesn't recognise your USB stick as a bootable device, then I'd say the chances are that the OS image may not have been written correctly to the USB stick. There are some instructions around the forum and wiki to help with this (e.g. using Rufus on Windows, or dd on Linux).
  • Ravenix
    Ravenix New Member Posts: 4
    Thanks for your reply Dan! The problem was that there is no possibility to use legacy boot, only UEFI. I also had a lot of trouble using PXE boot with the UP boards because of this same issue. I just stop using CoreOS and started using Ubuntu, It wasn't what I planned to do, but now I can continue.
  • C.R.
    C.R. New Member Posts: 2
    I installed the latest core os alpha release on my up2 successfully today.
    - I simply used the ubuntu-iso image (booted from usb) using the live-mode.
    - following the instructions from https://coreos.com/os/docs/latest/installing-to-disk.html
    - installed gawk on ubuntu: sudo apt-get install gawk
    - executed: coreos-install -d /dev/mmcblk1 -C alpha
    - executed efibootmgr to add uefi boot-option: sudo efibootmgr --create --disk /dev/mmcblk1 --part 1 --label "COREOS" --loader \\EFI\\boot\\grub.efi
    - rebooted into COREOS

    coreos is running fine so far on my up2

    next:
    - add ssd
    - add sata-disks
    - install zfs-modules in coreos
  • C.R.
    C.R. New Member Posts: 2
    edited June 2017
    Ok a small update here:
    I installed zfs-modules for coreos now and I did some performance-tests using a 4-bay sata-disks device connected via esata-port multiplier or usb.

    - zfs-modules for coreos can be built using the script from https://github.com/varasys/corezfs/blob/master/corezfs directly on the up2 (takes ~ 20 minutes to compile)
    - using this device: https://www.amazon.de/ORICO-eSATA-Festplattendockingstation-Festplatten-Speicherkapazität/dp/B013ZUD70Q to do some of the following io-performance-tests
    - i have a raidz pool on 4 x 2TB WD-Disks with 90 GB data on it and simply did a zpool scrub
    - I don't have any ssd-cache in use so far

    Results:
    Using the sata-port and port-multiplier (using an sata to esata-cable) on the up2:
    90.8G scanned out of 90.8G at 63.1M/s
    load average: 2.56, 2.31, 1.55

    Using the usb-port on the up2:
    90.8G scanned out of 90.8G at 118M/s,
    load average: 1.71, 1.74, 1.70

    So the usb-connection is twice as fast as the sata-port (using port-multiplier) and uses less cpu-ressources for this simple test.
    Don't know exactly where the bottleneck for the sata-port is located.
    Maybe it is simply due to the 4-bay sata-disks device I'm using for the test.
  • WereCatf
    WereCatf New Member Posts: 201
    edited June 2017
    Sounds to me like the SATA-port was running at SATA2-speeds, not SATA3 -- the theoretical max. for SATA2 is 300MB/s, you had 4 drives, which would give a theoretical speed of 75MB/s, but obviously you'll never reach theoretical speeds as there are always some losses, so the ~63MB/s you were getting sounds about right.

    USB3.0 tops out at a theoretical speed of 500MB/s, and again, divided by four that'd be 125MB/s, but given the real-world losses, 118MB/s sounds about right.

    The CPU-load when using SATA was higher simply due to the CPU having to wait longer for I/O.
  • ccalde
    ccalde New Member Posts: 348 ✭✭✭

    Hi all,

    Here you have a first PXE boot tutorial for Linux on UP platforms:

    https://wiki.up-community.org/Enable_PXE_boot