Up-board does not shutdown

PascalPascal New Member Posts: 3
Hi,

Spent several hours trying to figure out why my Up-board does not shutdown anymore with Ubuntu 14.04.
It's happy to shutdown, however after a couple of seconds will reboot again. Things I have tried unsuccessfully:
1. change the /etc/default/grub file (including adding acpi=off , acpi=noirq) and 'sudo grub-update'
2. Re-install Ubuntu 14.04 64b and up-board kernel
3. Install Ubuntu 16.04 64b and up-board kernel
4. Upgrade firmware to the latest version (go_64)

Non of this worked.

The power button will shutdown the board, but this cannot be done by software such as 'sudo shutdown -h now' of 'sudo poweroff'). Does anyone has any idea?

Regards,
Pascal.

Comments

  • PascalPascal New Member Posts: 3
    Could someone reply to this? I am using the Up-board to create a ROS based mobile robot so it's important to be able to shutdown the up-board by software to preserve battery power. Is this a Ubuntu issue, a firmware issue, or a specific to my hardware (faulty up-board)?
    Regards,
    Pascal.
  • Dan O'DonovanDan O'Donovan Emutex Posts: 223 mod
    Hi Pascal

    Personally, I've only seen this happen on one pre-production UP board. I'm not aware of any other occurrences of this issue on other UP boards except yours. Considering that, and the steps you've tried so far to rectify it, I suspect the issue might be a faulty UP board.

    I suggest contacting the UP shop to see if the board can be returned and fixed/replaced.

    Best regards,
    -Dan
  • PascalPascal New Member Posts: 3
    Thanks Dan.
    To rule out Ubuntu, I have installed Ubilinux 3 with the same result.
    I will contact the UP shop and see how we can resolve this.

    Regards,
    Pascal.
Sign In or Register to comment.