Possible BIOS corruption

cde1cde1 New Member Posts: 15
edited August 2016 in UP board BIOS

I have received my active cooler and installed it. However when powering up, the fan did not start :(

Also, I had not booted the board for several weeks, and it failed to boot Debian like it used to before, instead dropping to a UEFI shell. When I press Esc, it asks for a password (I never set a password).

This is quite unexpected, and I was wondering if someone from the UP team would be so kind as to troubleshoot me through these issues.


  • DCleriDCleri Administrator, AAEON Posts: 988 admin

    I am sorry to read about the issues you encountered.

    About the active cooler, did you connect the pins to the mini header correctly? Can you post a picture?

    About the system dropping to EFI shell, we would like to provide you some instructions by tomorrow to gather some information and help us to understand what have been caused the issue.

  • cde1cde1 New Member Posts: 15

    Thanks for the very fast reply!

    Yes, the pins are properly connected, like the RTC battery is (there is only one way to plug it anyway). I will check tomorrow with a voltmeter to see if the pins to actually provide voltage. Let me know what to input in the UEFI shell and I'll be able to try it out.
  • cde1cde1 New Member Posts: 15
  • cde1cde1 New Member Posts: 15
    So first of all the fan issue is solved, it had to be plugged in the 10-pin header, not the other header next to the CMOS battery. Now it works fine, which is great!

    About the BIOS, I can press enter at the password prompt but I only have "user" permissions. I noted the date was reset to 2012 which probably means the settings were lost, and since this board supports secure boot I assume the secure boot setting was reset too (hence the inability to boot Debian). So how to I disable secure boot? I assume this BIOS has a default admin password.
  • DCleriDCleri Administrator, AAEON Posts: 988 admin
    Hi cde1,

    It is great that you sorted already the issue with the fan.

    Thanks for the valuable feedback on the boot issue.

    Would it be possible for you to use the following Boot Repair tool only to gather information and share with us? (use the Create BootInfo Summary)

    Please do not attempt to repair the boot with it, as we don't know if that can solve the issue. Also it will help also others in the future if we can understand and solve the root cause of the issue.

    You can send the logs to "community AT up-board.org"
  • cde1cde1 New Member Posts: 15
    edited August 2016
    Thanks again dcleri. In the meantime I found the problem as well as the solution, which is similar to what you suggest.

    Problem: the RTC battery is no longer working, and when I unplug the board it loses all settings, including date/time but also how to boot into grub due to nvram being reset.

    Solution: booting with a Debian iso into rescue mode and choosing to reinstall grub solved it, although the problem will probably reappear the next time I unplug the board. If UP would be so kind and send me a replacement RTC battery, I'd be delighted!
  • cde1cde1 New Member Posts: 15
    I measured the voltage of the CR2032 RTC battery which is 3.1V as one would expect. So I'm not completely sure what is causing this issue, perhaps it is instead a bad contact at the connector that would cause this nvram resetting issue.
Sign In or Register to comment.