Cannot shutdown or reboot after Kernel 5.0.0 upgrade

AchmadFathoniAchmadFathoni New Member Posts: 5

I have tried to increase /proc/sys/kernel/watchdog_thresh to 60 but it still not work. I cannot find the full log because every time this stuck happens I must plug-off the power cable. I use Ubuntu 18.04.4


  • chris_yokumchris_yokum New Member Posts: 2

    I have had the same issue with stock 18.04 kernels, the 19.10 kernel, and the upboard kernel from the ppa: Linux upboard 5.0.0-1-generic #2~upboard5-Ubuntu

    In all cases, reboot/shutdown hangs with the same messages you see.

  • DCleriDCleri Administrator, AAEON Posts: 1,004 admin

    Hi @AchmadFathoni and @chris_yokum

    Thanks for reporting the issue and the additional details on other kernels having the same.

    We will investigate it further and come back to you.

  • tcb2tcb2 New Member Posts: 1


    'Hang on shutdown or reboot with certain releases. This is a problem related to kernel modules for HSUART DMA support that get loaded. The HSUARTs on the SOC are not normally used on the AtomicPi, however they do appear on the 26pin connector. The HSUARTs can still be used in PIO mode even after disabling DMA support, but will be less CPU efficient. To permanently prevent the modules from loading, edit the file /etc/modprobe.d/blacklist.conf and add lines to the bottom... "

    blacklist dw_dmac_core
    install dw_dmac /bin/true
    install dw_dmac_core /bin/true

  • janindujanindu New Member Posts: 1

    Hi @DCleri,

    Any updates on this? I still have this problem with the stock 18.04 kernel and the UP custom 5.0.0 kernel.

    Up board hangs on reboot / shutdown.


Sign In or Register to comment.