Enable GPIO interrupt under windows 10

Options

Hi I'm trying to enable HAT GPIO pin as interrupt under windows 10 using rhproxy,
but rhproxy gpio tool shows interrupt enables failed in all pins.

Could you help on this?
I've attached the acpitabl I used.

ps. I have tried I2C, and it works fine.

Tagged:

Answers

  • JunYing
    JunYing New Member, Moderator, AAEON Posts: 8 admin
    Options

    Hi @tylor_yang
    On using rhproxy,please check bios setting correctly,if use gpio,bios need to change pin to gpio and direction need to set because of cpld control cpu to HAT pin and HAT pin to CPU

  • tylor_yang
    tylor_yang New Member Posts: 5
    Options

    Hi JunYing,

    I've tried set all possible GPIO to input for interrupt pin, but its the same.
    Could you give detailed working instruction?

    Thanks.

  • HarryChiu
    HarryChiu New Member Posts: 119 ✭✭✭
    Options

    Hi Sir

    There is a CPLD between CPU and HAT pins.
    The rhproxy uses the built-in driver of Windows and cannot control CPLD.
    If you want to interrupt GPIO by acpi, need to change HAT pins configurations in bios.
    Adjust pin to "input" which you want to use.
    It can be used as long as the declaration and bios settings are correct.

    Best Regards,
    Harry Chiu

  • tylor_yang
    tylor_yang New Member Posts: 5
    edited November 2023
    Options

    Hi Harry,

    I know that part, please see below two images. I used I2C1 as bus and have set all other pins to
    input in BIOS. But still can't set interrupt in windows 10.

    Could you verified on the board?


  • StinkyTofu
    StinkyTofu New Member Posts: 1
    Options

    any update?

    I have the same problem here when try using Windows KMDF to get interrupt working on any GPIO in HAT40.

    It looks like the new FPGA solution has compatibility issue, comparing to old Intel Max5.
    Probably needs BIOS hotfix, not just by BIOS menu setting.

Privacy Policy