Does the UP Board UEFI BIOS version UPC1DM15 - have 32-bit BIOS?

Zach HershbergerZach Hershberger New Member Posts: 5

I am having trouble because I am running a Windows 10 32-bit OS and I just received new UP boards that have a 64-bit BIOS. I am currently unable to load my image or change the BIOS to 32-bit.

The problem is the new boards came with UPC1DM15 which from what I can tell is only 64-bit. I tried to downgrade to the old 32-bit BIOS (UPC1BM0X) I was flashing my systems (which is working on my original systems).

Whenever I try to run the go_64_32.nsh I get the following error: "4 - Error: ROM file ROMID is not compatible with existing BIOS ROMID." Which is most likely since I am attempting to downgrade the BIOS.

Anyone have a 32-Bit UPC1DM15 BIOS?

Comments

  • EmbeddedSchreckEmbeddedSchreck New Member Posts: 2

    Hi, did you found any 32 bit bios for the UP board until now. I searched for it but nothing found. It would be great if you would share it. Thanks a lot.
    Best Regards

  • DCleriDCleri Administrator, AAEON Posts: 840 admin

    32bit BIOS was only supported with the first revision of the BIOS, but it is not supported anymore

  • EmbeddedSchreckEmbeddedSchreck New Member Posts: 2

    Hi thank you for reply. But I don't understand your answer correctly....
    => I would need this old version?
    I have a SOIC onboard flash device. So it would be possible for me to flash the BIN to the UP board.

    My general Problem: I have a 1GB up board. I tried to get windows running on it. But Win10 - 64 bit can not be installed, because not enough memory (create Ramdisk failed during installation). So I want to try Win 10 - 32 Bit, because 1GB should be enough for the 32 bit version. But this 32bit installation does not boot out of 64Bit uefi...

    Best Regards

  • DCleriDCleri Administrator, AAEON Posts: 840 admin

    Hi @EmbeddedSchreck

    Unfortunately we cannot support 32bit OS and BIOS so the only way would be to install Windows IoT Core image or Linux.

Sign In or Register to comment.