Some "WiFi kit for UP" randomly disapear from Windows Device Manager.

PPU New Member Posts: 9


We have encountered a problem with around 10% of our ~60-80 "WiFi kit for UP". These Systems (UpBoard 4/32 Passive + WiFi kit for UP) works normal till a point where the internet connection is lost. A closer look at the network connections reveals that there is no WLAN Network/Chip Windows can see (only Ethernet is left).

The solution: Sometimes a simple reboot works, often it needs 3 or 4 of them (including power cut), and from time to time the power needs to be cut for several minutes (obvious I can't test this perfectly but my Testsystem right beside me had this problem yesterday and ~5-10 seconds wasn't enough, I thought the WLAN Chip was broken, I tried it finally for around 5 minutes and now it works again). BIOS is at default Settings.

Did you know of such Problems? I could believe that 1-5% of the modules could be faulty if they were cheaply made in China, but 10% (or more, we couldn't get the exact number if customers reboot it without telling us)!?



  • uscdadnyc
    uscdadnyc New Member Posts: 34 ✭✭

    Please note that my Suggestion is from the Perspective of a Hobbyist. May Not be applicable if you are in a Commercial Environment. That being Said. Consider using a USB WiFi Noob (Noob = USB Dongle). Worked for me in my UP-Board. Had also bought UP-WiFiKit-A10-7001 (in 2017). Only recently found out the UP video concerning Set-Up for this Kit. Alas, that Ship has sailed. I am happy w/ my UP-Board running WIN10 and using a USB WiFi Noob.

Privacy Policy