[Solved] UP CORE WiFi does not work Ubuntu 16.04

pgugi New Member Posts: 3
edited March 2020 in UP Core Linux

I just got UP CORE board and installed Ubuntu 16.04 ( downloaded from the link provided by UP BOARD ). I installed with option to erase everything and make a new installation. The installation was successful, but I can not run WiFi interface. I tried all the suggestions from the forum, but there is no success - it is like there is no wifi at all. Do I need to install special additional drivers and how can I get them ?


  • ccalde
    ccalde New Member Posts: 348 ✭✭✭

    Hi @pgugi ,

    To enable the WiFi and BT on UP Core board you will need to install the Ubuntu 16.04.5 with our upboard kernel 4.15 via PPA.
    After that, you have to install the Ampak firmware via PPA as well and then, after rebooting you will get your WiFi working properly.

    Please, confirm you followed all the steps from the Ubuntu area in the UP Wiki:

  • ztl
    ztl New Member Posts: 1

    Hi everyone,

    I have a similar issue as @pgugi . I followed the instructions on the Wiki und installed Ubuntu 18.04.4. After installing the package firmware-ampak und rebooting, I am still not able to use the Wi-Fi Adapter. In the system settings it even says: "No Wi-Fi Adapter Found". Bluetooth and the HAT work just fine on the other hand.

    Looking forward to your help.

This discussion has been closed.
Privacy Policy